Copyright © 2026 World Wide Web Consortium. W3C® liability, trademark and permissive document license rules apply.
本文档定义了一种通过 HTTP 和 DOM 传递的信号,用于传达个人请求网站和服务不要将其个人信息出售或分享给第三方的意愿。本标准旨在配合现有及即将实施的法律框架,使此类请求具有可执行性。
本节描述了本文档在发布时的状态。当前 W3C 出版物列表以及本技术报告的最新修订版可在 W3C 标准与草案索引中找到。
作为工作草案发布,并不代表 W3C 及其成员的认可。
本文档为草案,可能随时被更新、替换或废弃。将本文档作为正式引用是不合适的,仅可视为工作进展。
本文档由遵守 W3C 专利政策 的小组制定。 W3C 维护着 与小组交付物相关的专利公开公示列表; 该页面还包含专利公开的说明。若个人实际知晓某项专利并认为其包含 必要声明 ,则须根据 W3C 专利政策第6节 披露相关信息。
本文档受 2025年8月18日 W3C 流程文档管理。
本节为非规范性内容。
如今构建网站通常需要依赖由用户选择与之交互的企业之外的其他企业所提供的服务。这一结果是 Web 技术日益复杂以及不同服务之间分工的结果。虽然这种架构可以用于提供更好的 Web 体验, 但它也可能被滥用,从而侵犯隐私([privacy-principles])。虽然数据可以出于有限的运营目的与服务 提供商共享,但也可能以许多用户认为不可接受的方式被共享或用于 行为定向。
世界各地的司法辖区已经提出或制定了若干不同的法律框架来解决这一问题。一些模式依赖用户同意进行跟踪。另一些 基于数据最小化原则的模式则直接完全禁止某些数据共享或 数据处理。
一些法律和提案赋予用户请求保护其隐私的权利,包括“选择 退出”请求,即要求其数据不得出售或共享给 用户打算与之交互的企业以外的主体。然而,要求人们针对其访问的每一个网站手动表达自己的 权利是不切实际的,同时也是将“隐私劳动”强加给 人们 ([privacy-principles])。
本规范针对上述最后一类法律而设计,并通过提供一种方式,使个人能够通过 HTTP 标头 或 DOM 向所有网站发布者普遍发送信号,表明其主张适用的权利,以阻止其数据被出售、 其数据与第三方共享,以及其数据被用于跨上下文定向 广告,从而解决用户选择难以规模化的问题。该信号允许用户利用其中一些基于全局 选择退出 的法律中的特定条款,例如《加利福尼亚消费者隐私法》中与“选择退出偏好 信号”相关的条款,用于阻止个人信息的出售或共享, [CCPA-REGULATIONS],或科罗拉多州 及其他州法律中针对“通用选择退出 机制”的类似条款,使用户能够选择退出其信息的出售或其信息被用于 跨组织定向广告。
然而,虽然全局隐私控制旨在允许用户表达选择退出 共享和跨上下文定向广告的偏好,但该控制并非用于行使所有可能的 隐私权,甚至也不是用于行使所有退出广告或广告定向的权利。例如,GPC 并非用于 行使删除权。GPC 也并非用于处理同一上下文内的数据收集或广告定向。 有关更多详细信息,请参阅 法律和实现考虑 指南。
本规范不应被解释为对基于选择退出的监管模式 ——或更广泛意义上的跨上下文跟踪——的认可,也不应被解释为对其他基于 同意或数据最小化模式的否定。相反,它旨在使用户能够行使某些司法辖区 赋予他们的积极权利。
不出售或共享交互是指与 网站之间的一种交互,其中 个人请求其数据不得出售给或共享给其打算与之交互的主体以外的任何主体, 或请求其数据不得用于跨上下文广告定向。 就 W3C 的 隐私 原则而言,该个人至少 请求只存在一个数据控制者, 并且数据不得用于另一个 上下文中的广告定向,即使 该上下文由 同一企业所有。
不出售或共享偏好是指 个人 请求 其数据“不得被出售或共享”,例如通过其用户代理启用全局隐私控制 设置,或者使用默认采用此类设置的工具(这可能 是因为该设置符合该工具大多数用户最普遍的预期)。 设置后,此偏好表示该个人期望使用 不出售或共享交互来浏览 Web。
源可以在 .well-known URL 处提供一个资源,用以表示其 遵守 GPC 请求这一事实,至少在被要求这样做的情况下如此。GPC 支持资源的目的 是让源表明其知晓并支持其所提供页面上的全局隐私控制。该 支持资源并非用于表示该源是否遵守访问该资源的用户代理发出的 GPC 请求。 默认情况下,源的支持状态为未知。
GPC 支持资源具有相对于源服务器 URL 的 well-known 标识符 /.well-known/gpc.json
[RFC8615]。
收到以其 GPC 支持资源为目标的有效 GET 请求的源服务器 要么返回一个成功响应,其中包含机器可读的表示,说明 从该源提供的页面如何遵守 GPC, 要么返回一系列重定向,最终指向 这样的表示(该表示可以由另一个源上的服务器提供)。
源服务器必须使用
application/json 媒体类型 [RFC8259]
将 GPC 支持资源作为有效表示返回,
否则
该源的支持状态为
未知。
GPC 支持表示必须是一个 JSON 对象,否则 该源的支持状态为未知。本规范未在下方列表中列出的该 JSON 对象成员不具有任何 含义,并且必须被忽略。成员包括:
gpc 成员。gpc 成员的值必须为
以下之一:
true,表示服务器打算遵守 GPC 请求,至少
达到其法律义务要求的程度;或者 false,表示
其不打算遵守。对于任何其他值,该源的支持状态均为未知。
lastUpdate 成员。lastUpdate
成员的值必须为 RFC3339 full-date(YYYY-MM-DD)或
date-time
(YYYY-MM-DDTHH:mm:ss.sssZ)[RFC3339]。这表示
作出支持声明的
时间,从而使以后 GPC 标准含义的变化不应出于法律目的影响对该资源的解释。
如果该成员不是有效的 RFC3339 格式,则最后更新时间和日期
未知。
本节为非规范性内容。
GPC 信号旨在让用户能够利用法律赋予的权利,阻止其数据的某些 共享或处理。因此,发送和接收 GPC 信号可能 产生法律效力,具体取决于发送 信号的个人所在位置、适用法律的范围,以及 信号接收者与该个人之间是否存在任何单独协议等因素。不过,GPC 并不一定旨在援引 每个司法辖区中的每一项新隐私权。有关法律效力的更多详细信息, 请参阅法律和 实现考虑指南。
例如,在适用的情况下,个人使用 GPC 信号旨在表达 其援引以下权利的意图:
希望了解在特定司法辖区中应用 GPC 信号的最佳方式的监管机构和实现者,可以参考 W3C 的 隐私 原则中详细说明的全局选择退出机制的语义, 因为对于不太熟悉 Web 上用户代理所承担预期的人来说,其中的具体细节可能并不熟悉。
GPC 最初是为了利用美国新出现的选择退出隐私法律而创建的。 自 2018 年《加利福尼亚消费者隐私法》颁布以来,美国多个州 已通过隐私法律,赋予消费者选择退出其数据出售或共享, 或选择退出其数据被用于跨组织定向广告的法律权利。其中许多州 的法律明确规定可以通过 GPC 等通用选择退出机制 行使这些权利。至少有四个州已经明确认定 GPC 是行使 法定选择退出权利的有效方式。少数州规定了规则制定程序,以允许监管机构 进一步明确应如何遵守通用选择退出请求;其他州可能 依靠非正式指导或执法行动,来明确围绕 GPC 信号的法律 义务范围。
GPC 也可能被用于表示其他司法辖区中的权利。例如, GDPR 可能根据第 7 条和第 21 条赋予数据主体限制共享个人信息的权利。 世界许多其他国家也已通过积极的隐私 立法——通常以 GDPR 为范本;其中某个国家的监管机构可能认定 GPC 援引了一项法律权利,从而要求接收者作出某种响应。
弗吉尼亚州和犹他州等其他美国州的隐私法律,为消费者提供了 针对数据出售和跨组织定向广告的新选择退出权利,但并未规定 全局选择退出信号的法律效力。执行这些法规的监管机构可能认定,用户 启用 GPC 等信号可能足以在 这些司法辖区中合法行使选择退出权利。
不过,GPC 并不一定旨在援引每个 司法辖区中的每一项新隐私权。例如,GPC 并非旨在对 用户访问的每个网站全局援引数据删除权。GPC 也并非旨在限制第一方在 同一上下文中使用个人信息(例如发布者 根据用户之前在同一 上下文中的活动,在其网站上向该用户定向投放广告)。
考虑到现有同意框架的复杂性,接受 GPC 信号的发布者 应披露其在该司法辖区中如何处理 GPC 信号,以及如何处理 该信号与个人此前直接向发布者作出的其他特定隐私选择之间的冲突, 包括允许第三方共享的情况,例如向服务 提供商/处理者共享、 根据法律要求共享,或按照 个人指示进行共享。
本文档未规定在启用 GPC 之前必须向用户呈现哪些信息。当用户代理推广某项隐私功能或提供某项隐私设置时,它可以根据 已向用户披露的内容确定发送 GPC 是否适当。 用户代理应当努力表示用户代理认为最能代表 个人 对全局隐私控制值的偏好。尽管研究表明大多数人并不 希望其数据被出售或共享,但一些司法辖区已经制定了“选择退出”法律框架, 要求消费者采取主动行动来表达偏好,从而限制 数据 共享或其数据被用于定向广告。GPC 旨在让用户轻松 利用这些法律。
不同司法辖区对平台启用 GPC 等通用 选择退出机制之前所需满足的先决条件有不同规定。美国许多州规定,用户代理不得 “默认”发送通用选择退出信号,不过至少有一个州表示,选择注重隐私的用户代理 足以表示用户意图。
不同司法辖区对于公司何时可以覆盖或忽略 普遍适用的选择退出信号,也可能具有不同规则, 例如因为公司已获得用户同意。
围绕全局选择退出的法律环境也在不断变化。已有多个州通过了 包含必须遵守全局选择退出要求的法律,不过其中一些州的规定 存在显著差异。此外,各州可能修改其法律要求,例如加利福尼亚州已经 修订了 2018 年通过的原始 CCPA。
除美国之外,其他司法辖区也可能承认通用隐私信号, 并可能在这类信号被视为具有法律约束力之前施加自己的要求。
有关最新法律要求的更多信息,请查阅 法律和实现 考虑指南,其中将提供有关全局选择退出的最新法律 指导的 更及时信息。
在有相关要求的情况下,用户代理应向人们呈现所有适当的通知, 以确保他们希望行使的权利能够有效产生约束力。
暴露用户的偏好(通过 HTTP 标头字段或navigator
对象)
可能会以一种增加
可用于浏览器或设备指纹识别的信息的方式,将用户分成两个群体。除非该信号
与其他信号完全相关,或者在不可配置的设置中启用,否则这些附加信息
都是可用的。因此,根据具体实现,GPC 信号可能会带来
一定的隐私成本,不过这种成本旨在由发送该
信号所带来的隐私收益加以合理化。
本规范中的功能不存在已知的安全影响。
| HTTP 方法 | URI 模板 |
|---|---|
| POST | /session/{session id}/privacy |
设置全局隐私控制扩展命令修改当前会话的 不出售或共享偏好,并 返回 更新后的设置。
给定 session、URL variables 和 parameters,远端 步骤如下:
| HTTP 方法 | URI 模板 |
|---|---|
| GET | /session/{session id}/privacy |
给定 session、URL variables 和 parameters,远端 步骤如下:
除标记为非规范性的章节之外,本规范中的所有创作指南、图表、示例和注释 均为非规范性内容。本规范中的其他所有内容均为规范性内容。
本文档中的关键字可以、必须、不得以及 应当 应按照 BCP 14 [RFC2119] [RFC8174] 中所述的方式解释,但仅限于这些关键字像此处所示那样全部以 大写形式出现时。
值得考虑的是,GPC 信号将附加到向给定 网站发出的每个 HTTP 请求。渲染一个 Web 页面通常需要发出数十个这样的请求。因此, 如果每一次 GPC 交互都触发带有 高成本审计跟踪的完整选择退出程序,可能并不切实际,因为这会产生大量 处理工作,包括必须 尽可能高效执行的、由内容分发网络(CDN)提供的资源相关处理。
旨在支持 GPC 的法规应考虑此类实现 困难。解决这些困难的一种方式,是区分为用户提供、用于请求使不出售或共享交互偏好在网站上持续存在的用户界面 功能,以及提供由用户代理维持其状态的 不出售或共享交互信号。 在后一种情况下,可以像该个人先前已经请求过这样的不出售或共享 交互偏好, 并且正在与已经启用该偏好的状态交互一样处理该交互。
Referenced in:
Referenced in: